Много ошибок в последней версии Human Emulator Studio

вопросы связанные с работой версии с Chromium
Аватара пользователя
bigfozzy
Site Admin
Сообщения: 2996
Зарегистрирован: 28 июл 2008, 17:24
Контактная информация:

Re: Много ошибок в последней версии Human Emulator Studio

Сообщение bigfozzy » 05 апр 2022, 16:50

Спасибо за развернутый ответ. Принято. Завтра в 9-00 начнем копать в чем дело. В 17-00 отпишусь о результатах.

Аватара пользователя
bigfozzy
Site Admin
Сообщения: 2996
Зарегистрирован: 28 июл 2008, 17:24
Контактная информация:

Re: Много ошибок в последней версии Human Emulator Studio

Сообщение bigfozzy » 06 апр 2022, 07:55

sashawww писал(а):
05 апр 2022, 15:27
И второе, вот на примере сайта tumblr.com - раньше работало всё (в версии HE Studio 7.0.59). В сегодняшней версии не работает ничего.
С трудом зарегистрировался, после чего даже форма для добавления нового поста не грузится - думает и выдаёт ошибку "Error loading forms. Hmm. This doesn't seem to be worked. Please try again."
Там сейчас практически ничего не грузится, даже картинки к постам.
____
Давайте пока сконцентрируемся на этих двух пунктах. Пожалуйста, не затягивайте - отдайте в работу сразу.
Только что - установили в новую папку и зарегистрировались руками (без и с прокси, но без смены настроек
tumblr.png
tumblr.png (124.44 КБ) 232 просмотра
)

Аватара пользователя
bigfozzy
Site Admin
Сообщения: 2996
Зарегистрирован: 28 июл 2008, 17:24
Контактная информация:

Re: Много ошибок в последней версии Human Emulator Studio

Сообщение bigfozzy » 06 апр 2022, 08:16

sashawww писал(а):
05 апр 2022, 15:27
Да, давайте начнём с чего нибудь одного. Скачал и проверил на версии программы, которую выложили сегодня. Модель браузера Chromium.
Есть такой неприятный для меня баг, который пояился примерно с версии Human Emulator Studio 7.0.60 и кочует из версии в версию.
На многих сайтах, таких как twitter, yandex и других аватар аккаунта и фон к нему загружаются сильно засвеченные, как будто на них наложили фильтр.
Раньше аватары засвечивались сильно синим цветом, в последней версии они просто засветляются.
Вот пример:
https://twitter.com/Cynthia85564292 - сделал в Human Emulator Studio 7.0.67 (сегодняшней)
https://twitter.com/Cynthia44751636 - сделал в настоящем браузере сегодня
А подскажите - при загрузке аватаров вы Canvas FP и WebGL FP меняете ? А прокси у вас картинки не жмут ? И какой командой их грузите или просто руками ?

Вот только что добавили - без изменения настроек, c прокси :
twiter.jpg
twiter.jpg (153.61 КБ) 230 просмотров

Аватара пользователя
sashawww
Сообщения: 52
Зарегистрирован: 15 дек 2009, 03:26

Re: Много ошибок в последней версии Human Emulator Studio

Сообщение sashawww » 06 апр 2022, 23:48

bigfozzy писал(а):
06 апр 2022, 08:16
А подскажите - при загрузке аватаров вы Canvas FP и WebGL FP меняете ? А прокси у вас картинки не жмут ? И какой командой их грузите или просто руками ?
Гружу обычной командой
$window->execute_open_file("ф",$twitter_avatar,"&Открыть",false,true); 
, пробовал и вручную.
Пробовал и с прокси и без.
А вот отпечатки Canvas FP и WebGL FP меняю, вообще практически все возможные параметры браузера меняю: разрешения экрана, языки, в том числе и все отпечатки.
Сегодня с утра начал отключать их по одному и тестировать и, ВДРУГ, отключив
$browser->set_canvas_toDataURL($canvas_toDataURL);
аватары стали грузится нормально.

Вот код:
$browser->set_canvas_toDataURL();
/*
    // canvas_toDataURL
    $canvas_toDataURL = random_str(random_int(12,16), false); // random_str() просто генерит случайную строку из набора букв
    $browser->set_canvas_toDataURL($canvas_toDataURL);
    // \canvas_toDataURL
*/
Попробовал даже устанавливать canvas через настроки - там генерится случайное число от 1 до 9999 - то же самое.
Если canvas сгенерен - аватары загружаются неправильные, засвеченные. Стоит его только отключить - в всё загружается как нужно.

Причина установлена, теперь остаётся поправить метод
$browser->set_canvas_toDataURL()
Кстати, есть такой сайт http://f.vision, так вот он, если подменять canvas, сразу детектит "Fake Canvas" (там нужно кликнуть Start Advanced Tests)
А сайт https://browserleaks.com/canvas на любой сгенеренный Canvas пишет Uniqueness 100% (что очень плохо - должно быть меньше 100%)
И в настоящем canvas фон прозрачный, а при сгенеренных canvas фон или синий или зелёный, вообщем с неми не всё хорошо.

Во-вторых, установив сегодняшнюю версию Human Emulator Studio с юбилейным 100-м chromium обнаружил, что на tumblr всё стало хорошо. И посты на инстаграме починились.

Так что, если вкратце, прошу рассмотреть ещё 2 пункта:

1. Починить метод $browser->set_canvas_toDataURL() чтобы он генерил корректные canvas. Может возможно сделать, чтобы сразу подставлять в этот метод готовую Signature (из сайта https://browserleaks.com/canvas - тогда всего-то нужно было бы иметь набор корректных сигнатур и подставлять их в метод).
2. Зашёл на tiktok и всё ещё нельзя фолловить пользователей и ставить лайки (кнопка "Follow" нажимается, но если обновить страницу видно что подписка не поставилась). Также не проигрываются видео. Посмотрите пожалуйста tiktok, всё же это один из самых популярных сайтов в мире сейчас.

Ответить