Send_input периодически работает некорректно при ручной инициализации объектов DOM

Если вы обнаружили какие либо ошибки, недочеты и неудобства или другие незачеты в программе напишите нам об этом на этом форуме - мы бум исправлять
Ответить
alpha666
Сообщения: 40
Зарегистрирован: 03 фев 2017, 07:04
Контактная информация:

Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение alpha666 » 13 май 2022, 11:10

При инициализации объектов DOM вручную периодически возникают проблемы с командой send_input, а именно вместо того чтобы ввести строку хуман вводит только первый символ.

Пример:

Код: Выделить всё

	$input = new XHEInput('127.0.0.1:7011');
	$input->get_by_number(0)->send_input("Hello World");
Вместо строки "Hello World" хуман забьет только букву "H". Данная проблема возникает периодически, от чего зависит так и не понял.

Если объекты DOM инициализировать с помощью файла xweb_human_emulator.php, то все работает правильно, но для меня этот вариант не подходит.
Помогите разобраться
Программист извращенец из Киева - alphagoblin4@gmail.com

Аватара пользователя
bigfozzy
Site Admin
Сообщения: 2996
Зарегистрирован: 28 июл 2008, 17:24
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение bigfozzy » 13 май 2022, 19:30

попробуйте установить глобальную переменную: $PHP_Use_Trought_Shell=false;

alpha666
Сообщения: 40
Зарегистрирован: 03 фев 2017, 07:04
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение alpha666 » 16 май 2022, 10:16

Не помогло, ошибка по прежнему продолжает давать о себе знать. Может ли это быть как-то связано с командой

Код: Выделить всё

$debug->set_cur_script_path(__DIR__);
Программист извращенец из Киева - alphagoblin4@gmail.com

alpha666
Сообщения: 40
Зарегистрирован: 03 фев 2017, 07:04
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение alpha666 » 16 май 2022, 10:50

Забыл уточнить, у меня исполняемые скрипты находятся во внешней папке C:\xampp\htdocs\xhe\test
Программист извращенец из Киева - alphagoblin4@gmail.com

alpha666
Сообщения: 40
Зарегистрирован: 03 фев 2017, 07:04
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение alpha666 » 16 май 2022, 12:08

bigfozzy писал(а):
13 май 2022, 19:30
попробуйте установить глобальную переменную: $PHP_Use_Trought_Shell=false;
Вместо замены глобальной переменной (от их использования отказался для автоподгрузки классов через автолоадер) сделал замену в файле xhe_base_dom.php

Код: Выделить всё

$PHP_Use_Trought_Shell = false;

вместо

Код: Выделить всё

$PHP_Use_Trought_Shell = true;
Программист извращенец из Киева - alphagoblin4@gmail.com

Аватара пользователя
bigfozzy
Site Admin
Сообщения: 2996
Зарегистрирован: 28 июл 2008, 17:24
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение bigfozzy » 16 май 2022, 12:44

А замените в файле xhe_keyboard.php код функции send_input на этот и в самом хумане запустите скрипт с бесконечным циклом :

	// посылает ввод строки в браузер, даже если он скрыт
   	function send_input($string,$timeout="0:2",$inFlash=false,$auto_change=true)
   	{
		global $PHP_Use_Trought_Shell;

		$params = array( "string" => $string , "timeout" => $timeout , "inFlash" => $inFlash , "auto_change" => $auto_change );
		$res=$this->call_boolean(__FUNCTION__,$params);
		
		sleep(1);
		return $res;
   	}

alpha666
Сообщения: 40
Зарегистрирован: 03 фев 2017, 07:04
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение alpha666 » 17 май 2022, 09:23

Заменил, не помогло...
Программист извращенец из Киева - alphagoblin4@gmail.com

Аватара пользователя
bigfozzy
Site Admin
Сообщения: 2996
Зарегистрирован: 28 июл 2008, 17:24
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение bigfozzy » 18 май 2022, 19:30

А напишите нам в скайп или телграм - чтобы уделенно посмотреть ?

alpha666
Сообщения: 40
Зарегистрирован: 03 фев 2017, 07:04
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение alpha666 » 19 май 2022, 10:39

Оставьте ваш контактный телеграмм, пожалуйста
Программист извращенец из Киева - alphagoblin4@gmail.com

alpha666
Сообщения: 40
Зарегистрирован: 03 фев 2017, 07:04
Контактная информация:

Re: Send_input периодически работает некорректно при ручной инициализации объектов DOM

Сообщение alpha666 » 25 май 2022, 10:27

Связался с поддержкой, как оказалось, ошибка появлялась из-за неправильного запуска хумана (с помощью внешней команды): в команде запуска отсутствовали кавычки для параметров port и script
Правильный вариант запуска:

Код: Выделить всё

START "" "C:\XWeb\Human Emulator Studio 7.0.62\XWeb Human Emulator Studio.exe" /port:"7011" /script:"C:\XWeb\Human Emulator Studio 7.0.62\My Scripts\16.php"
Программист извращенец из Киева - alphagoblin4@gmail.com

Ответить